use strict;
my $str = '@abc @ijmn @123 @1a2b @abc.a @stu @x.yz @klm @2c3d
@a @ab @abc a@xyz !@ijmn,@123 0@321 @1a2b @qwerty @abc.a @stu..test _@nmp @x.yz.@klm @.1a2b .@2c3d.
';
my $regex = qr/@[1-3a-di-ns-ux-z.]{3,5}[\s]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}