// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d+(\.\d+)?%)").unwrap();
let string = "Bachelor of Engineering in Electronics from in 2013 with 60%.
Diploma (Electronics & Video Engineering) from in 2009 with 79.39%.
SSC from in 2006 with 61.71%.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}