$re = '/^(?:[2-9]|\d\d\d*)$/m';
$str = '1
2
3
4
5
10
100
1000
10000
111111
123
234
1234
12345
111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);