$re = '/^[^*]*\*$/m';
$str = 'abc*
123*
abc 123*
abc-123abc*
I dont want like this:
abc**
abc*123
*abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);