$re = '/^=\?(?<ifNull>(?:\\\\(\\\\\\\\)*:|[^:])*)(?<!\\\\):(?<ifNotNull>(?:\\\\(\\\\\\\\)*:|[^:])*)$/m';
$str = '=?This value would be returned if null or empty.:This would be returned if not.
=?This\\:is\\:a\\:demo of what \\:happens\\:with:an escaped \\: separator.
=?This is what happens with an invalid value.
and don\'t forget the =? on the front of the string:or you won\'t get any results.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);