$re = '/\b\d*[a-z][a-z\d]*/i';
$str = 'Abcd abcd1a 5ever qw3-fne superb5 1234 0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);