package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:\d+(?:-\d+)?),?)+$`)
var str = `1
1-2
1,23,1-4,5,23,123
1,2,3,4,5,6-10
1,123-123,4,1,66,123
1-2,2-3,3-4,4-5,6-7,8,9,10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}