package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`PT\d+ @ [\d.]+`)
var str = `abced @ 1.20689\nLS @ 1.22000\nPT1 @ 1.1900\nPT2 @ 1.1800
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}