import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\.(?![^.]+$)|[^\\w\\d\\n.])+";
final String string = "manuel fernandex – Index Prot.bla.otype 5 (pepito grillo).jpg\n"
+ "manuel-fernandex-Index-Prot-bla-otype-5-pepito-grillo-.jpg";
final String subst = "-";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}