re = /(?:\.(?![^.]+$)|[^\w\d\n.])+/m
str = 'manuel fernandex – Index Prot.bla.otype 5 (pepito grillo).jpg
manuel-fernandex-Index-Prot-bla-otype-5-pepito-grillo-.jpg'
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result