import Foundation
let pattern = #"(?:\.(?![^.]+$)|[^\w\d\n.])+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
manuel fernandex – Index Prot.bla.otype 5 (pepito grillo).jpg
manuel-fernandex-Index-Prot-bla-otype-5-pepito-grillo-.jpg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)