$re = '/^\d*::[a-zA-Z]+[^\(]*\(\d{4}\)::(?<disease>(?:HIV|Cancer|flu|Arthritis|OCD)(?:\|(?:HIV|Cancer|flu|Arthritis|OCD))*)$/m';
$str = '24::Robin (1980)::HIV|Cancer|Cancer|HIV
24::Robin (1980)::HIV|Cancer|Cancer|HIV|test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);