package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(([0-9\-\s,.]+)\)`)
var str = `(-6.2811957386588855, 106.70141951079609),(-6.281142416506361, 106.70432702536823),(-6.2781776962328815, 106.70438066954853),(-6.2781776962328815, 106.70136586661579)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}