re = /(\d+),([^,]*),([^,]*?)(?:\r?\n|$)/
str = 'id, text field1, text field2
1,some text,another text
2,some text,another text
3,some text,another text
1,some text,another text
2,some
text,another text
3,some text,another text
1,some text,another text
2,some
1999-06-21 text,another text
3,some text,another text'
subst = '$1, "$2", "$3"\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result