# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\|([\s\S]+?)\|//g;t' <<< "машина|жигули, тойота, ваз, заз||техника|мясорубка, телевизор, телефон, Q123||фрукты|яблоко, апельсин, банан, анонс, маракуя1||"