use strict;
my $str = 'машина|жигули, тойота, ваз, заз||техника|мясорубка, телевизор, телефон, Q123||фрукты|яблоко, апельсин, банан, анонс, маракуя1||';
my $regex = qr/\|([\s\S]+?)\|/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";