// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\|([\s\S]+?)\|").unwrap();
let string = "машина|жигули, тойота, ваз, заз||техника|мясорубка, телевизор, телефон, Q123||фрукты|яблоко, апельсин, банан, анонс, маракуя1||";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}