$re = '/(?:[^\|]\|)([^\|]+)(?:\|\|)/';
$str = 'машина|жигули, тойота, ваз, заз||техника|мясорубка, телевизор, телефон, Q123||фрукты|яблоко, апельсин, банан, анонс, маракуя1||';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;