package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^dev)|(^release\/.*)|(^master)|(PR-\d+)`)
var str = `dev
master
release/230444
defect/fix-it
chore/make-better
feature/click-it
PR-344
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}