package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(price=)\([^()]*?value=([\d.]+)\)`)
var str = `product,price=(decimals=4, value=7.505),quantity
product,(subporduct,(price=(decimals=4, value=7.05)),quantity
product,(subporduct,item=2, price=(decimals=4, value=7.05)),quantity`
var substitution = "\1\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}