using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|\b)([5,9]\d{2,}|\d{4,})(\.\d+)? (dollar|\$)(\b|\n)";
string input = @"501.34 dollar
500 dollar
I have 4500 dollar
1250.99 $
50000.252221121 dollar
200 dollar
350.99
I found new animal called 4500 dollariansaurus";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}