Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(^|\b)([5,9]\d{2,}|\d{4,})(\.\d+)? (dollar|\$)(\b|\n)
/
gm
Input 1
1
New
501.34 dollar 500 dollar I have 4500 dollar 1250.99 $ 50000.252221121 dollar 200 dollar 350.99 I found new animal called 4500 dollariansaurus