import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|\\b)([5,9]\\d{2,}|\\d{4,})(\\.\\d+)? (dollar|\\$)(\\b|\\n)";
final String string = "501.34 dollar\n\n"
+ "500 dollar\n\n"
+ "I have 4500 dollar\n\n"
+ "1250.99 $\n"
+ "50000.252221121 dollar\n\n"
+ "200 dollar\n\n"
+ "350.99\n\n"
+ "I found new animal called 4500 dollariansaurus";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}