const regex = /(^|\b)([5,9]\d{2,}|\d{4,})(\.\d+)? (dollar|\$)(\b|\n)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\b)([5,9]\\d{2,}|\\d{4,})(\\.\\d+)? (dollar|\\$)(\\b|\\n)', 'gm')
const str = `501.34 dollar
500 dollar
I have 4500 dollar
1250.99 \$
50000.252221121 dollar
200 dollar
350.99
I found new animal called 4500 dollariansaurus`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}