use strict;
my $str = '501.34 dollar
500 dollar
I have 4500 dollar
1250.99 $
50000.252221121 dollar
200 dollar
350.99
I found new animal called 4500 dollariansaurus';
my $regex = qr/(^|\b)([5,9]\d{2,}|\d{4,})(\.\d+)? (dollar|\$)(\b|\n)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}