import Foundation
let pattern = #"(^|\b)([5,9]\d{2,}|\d{4,})(\.\d+)? (dollar|\$)(\b|\n)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
501.34 dollar
500 dollar
I have 4500 dollar
1250.99 $
50000.252221121 dollar
200 dollar
350.99
I found new animal called 4500 dollariansaurus
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)