# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/{[^}{]*}(*SKIP)(*F)|,//g;t' <<< "{\"A\": \"B\", \"C\":{\"D\":\"E\"}, \"F\": {\"G\"}, \"H\":\"I\"}
{f,o,o} b,a,r {b,a,z}
{{a,a},{b,b},{c,c}}
"