// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"{[^}{]*}(*SKIP)(*F)|,").unwrap();
let string = "{\"A\": \"B\", \"C\":{\"D\":\"E\"}, \"F\": {\"G\"}, \"H\":\"I\"}
{f,o,o} b,a,r {b,a,z}
{{a,a},{b,b},{c,c}}
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}