import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "( [0-9]{2,3}.[0-9]{1} .[0-9]{2,3}.[0-9]{1} )";
final String string = "Start: 2020-02-01T10:08:41-0500\n"
+ "HOST: detectgooglesp.com Loss% Snt Last Avg Best Wrst StDev\n"
+ " 1.|-- 148.163.220.1 0.0% 15 6.3 9.1 2.9 32.7 7.8\n"
+ " 2.|-- 148.163.219.28 0.0% 15 3.1 7.0 2.3 22.4 5.0\n"
+ " 3.|-- 187.16.216.55 0.0% 15 5.5 6.6 2.9 16.6 3.3\n"
+ " 4.|-- 74.125.243.12 0.0% 15 7.4 6.1 3.6 10.6 1.9\n"
+ " 5.|-- 209.85.252.68 0.0% 15 18.2 16.7 3.6 14.1 3.0\n"
+ " 6.|-- 66.249.94.109 0.0% 15 108.3 110.1 106.7 120.9 4.1\n"
+ " 7.|-- 74.125.251.34 0.0% 15 120.9 122.9 120.2 130.5 3.0\n"
+ " 8.|-- 216.239.40.141 0.0% 15 131.0 129.6 128.1 132.3 1.1\n"
+ " 9.|-- 209.85.250.206 0.0% 15 141.0 145.7 141.0 162.7 5.8\n"
+ " 10.|-- 209.85.253.209 0.0% 15 154.8 144.7 140.6 155.0 4.4\n"
+ " 11.|-- 209.85.244.207 0.0% 15 141.9 152.6 141.9 229.7 22.7\n"
+ " 12.|-- ??? 100.0 15 0.0 0.0 0.0 0.0 0.0\n"
+ " 13.|-- ??? 100.0 15 0.0 0.0 0.0 0.0 0.0\n"
+ " 14.|-- ??? 100.0 15 0.0 0.0 0.0 0.0 0.0\n"
+ " 15.|-- ??? 100.0 15 0.0 0.0 0.0 0.0 0.0\n"
+ " 16.|-- ??? 100.0 15 0.0 0.0 0.0 0.0 0.0\n"
+ " 17.|-- ??? 100.0 15 0.0 0.0 0.0 0.0 0.0\n"
+ " 18.|-- ??? 100.0 15 0.0 0.0 0.0 0.0 0.0\n"
+ " 19.|-- ??? 100.0 15 0.0 0.0 0.0 0.0 0.0\n"
+ " 20.|-- ??? 100.0 15 0.0 0.0 0.0 0.0 0.0\n"
+ " 21.|-- 35.226.130.1 0.0% 15 144.5 143.1 141.1 151.6 2.6\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}