using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|/)((?:19|20)[0-9]{2})/((?:0?[1-9]|1[0-2])(?:-(?:0?[1-9]|1[0-2]))?)(?:/|$)";
string input = @"/www.site.com/path1/resort/2021/02/sitename
/www.site.com/path1/2021/02
/www.site.com/path1/2020/11-12
/www.site.com/path1/2020/07-08
/www.site.com/path1/resort/
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}