package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:en/)?\d{1,3}-[^/]+/$`)
var str = `12-blog/
12-blog/blog2/
en/12-blog/
en/12-blog/blog2/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}