re = /^(?:en\/)?\d{1,3}-[^\/]+\/$/m
str = '12-blog/
12-blog/blog2/
en/12-blog/
en/12-blog/blog2/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end