package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bEtc/\S*|(UTC|GMT)?([+-])(\d{1,2})([:.])?(\d{1,2})?`)
var str = `GMT+01:00
UTC+01:00
UTC+01
+01:00
Etc/GMT+01:00
Etc/UTC+01:00
Etc/UTC+01`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}