#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?|\d{2}(?=\d{9}$)|\d{3}(?!$))\K"
Local $sString = "90000800123987"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)