import Foundation
let pattern = #"(?|\d{2}(?=\d{9}$)|\d{3}(?!$))\K"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"90000800123987"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)