#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{1,3}(?:\.\d{3})*(?:,\d+)?$|^\d+(?:,)?\d+$"
Local $sString = "1.000,00" & @CRLF & _
".000,00" & @CRLF & _
".000.000,00" & @CRLF & _
"0.000,00" & @CRLF & _
"111" & @CRLF & _
"111,11" & @CRLF & _
"111.111,11" & @CRLF & _
"11.111.110,00" & @CRLF & _
"11.1111.11,00" & @CRLF & _
"111" & @CRLF & _
"11.11" & @CRLF & _
"1111.00" & @CRLF & _
"10111111,00" & @CRLF & _
"111.000," & @CRLF & _
"11.111,00" & @CRLF & _
"111111,00" & @CRLF & _
"10.000,00000000" & @CRLF & _
"1000.100.00" & @CRLF & _
"1.000.000,00" & @CRLF & _
"12.345,67"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")