# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\d{1,3}(?:\.\d{3})*(?:,\d+)?$|^\d+(?:,)?\d+$"
test_str = ("1.000,00\n"
".000,00\n"
".000.000,00\n"
"0.000,00\n"
"111\n"
"111,11\n"
"111.111,11\n"
"11.111.110,00\n"
"11.1111.11,00\n"
"111\n"
"11.11\n"
"1111.00\n"
"10111111,00\n"
"111.000,\n"
"11.111,00\n"
"111111,00\n"
"10.000,00000000\n"
"1000.100.00\n"
"1.000.000,00\n"
"12.345,67")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.