# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\\/(?<CONYY>\w{3,}\d{2})(\\/resources)*(\\/?|(\\/)*|(?<FILE>\\/index\.html))$/\/resources\/$<CONYY>\//gm;t' <<< "/yvr18/resources/index.html
/yvr18/resources/
/hkg18/index.html
/hkg18/"