#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\/(?<CONYY>\w{3,}\d{2})(\/resources)*(\/?|(\/)*|(?<FILE>\/index\.html))$"
Local $sString = "/yvr18/resources/index.html" & @CRLF & _
"/yvr18/resources/" & @CRLF & _
"/hkg18/index.html" & @CRLF & _
"/hkg18/"
Local $sSubst = "/resources/$<CONYY>/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)