package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/(?<CONYY>\w{3,}\d{2})(\/resources)*(\/?|(\/)*|(?<FILE>\/index\.html))$`)
var str = `/yvr18/resources/index.html
/yvr18/resources/
/hkg18/index.html
/hkg18/`
var substitution = "/resources/$<CONYY>/"
fmt.Println(re.ReplaceAllString(str, substitution))
}