# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\/(?<CONYY>\w{3,}\d{2})(\/resources)*(\/?|(\/)*|(?<FILE>\/index\.html))$"
test_str = ("/yvr18/resources/index.html\n"
"/yvr18/resources/\n"
"/hkg18/index.html\n"
"/hkg18/")
subst = "/resources/$<CONYY>/"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.