// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\/(?<CONYY>\w{3,}\d{2})(\/resources)*(\/?|(\/)*|(?<FILE>\/index\.html))$").unwrap();
let string = "/yvr18/resources/index.html
/yvr18/resources/
/hkg18/index.html
/hkg18/";
let substitution = "/resources/$<CONYY>/";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}