#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:(?<!:)\/\/.*|\/\*[\s\S]*?\*\/)(*SKIP)(*F)|while.+?[\s=(]each[\s(]"
Local $sString = "// bar bar" & @CRLF & _
"" & @CRLF & _
"while (list($key, $value) = each($_GET))" & @CRLF & _
"" & @CRLF & _
"/* some code" & @CRLF & _
" while (list($key, $value) = each($_GET))" & @CRLF & _
" some code" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"while (list($key, $value) = each($_GET))"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")