import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<!:)\\/\\/.*|\\/\\*[\\s\\S]*?\\*\\/)(*SKIP)(*F)|while.+?[\\s=(]each[\\s(]";
final String string = "// bar bar\n\n"
+ "while (list($key, $value) = each($_GET))\n\n"
+ "/* some code\n"
+ " while (list($key, $value) = each($_GET))\n"
+ " some code\n"
+ "*/\n\n"
+ "while (list($key, $value) = each($_GET))";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}