$re = '/(?:(?<!:)\/\/.*|\/\*[\s\S]*?\*\/)(*SKIP)(*F)|while.+?[\s=(]each[\s(]/';
$str = '// bar bar
while (list($key, $value) = each($_GET))
/* some code
while (list($key, $value) = each($_GET))
some code
*/
while (list($key, $value) = each($_GET))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);