// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\.(?<exName>[A-Za-z]+)\((?<exVal>[^()]*)\))+$").unwrap();
let string = ".Foo().Bar(20).Baz(Hello)
.Foo().Bar(20)k.Baz(Hello)hgjfvg";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}