# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G(?!^)|\bDenti)[^\W_]*\K_//g;t' <<< "Foo_Bar_baz Denti_Cal_Project_Status Baz_bar"