using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!^)|\bDenti)[^\W_]*\K_";
string substitution = @"";
string input = @"Foo_Bar_baz Denti_Cal_Project_Status Baz_bar";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}