using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<table class=\""datatable\s\"">(.*?)<\/table>";
string input = @"<table class=""datatable""><thead><tr><tr></thead></table>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}