// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<table class=\"datatable\s\">(.*?)<\/table>"#).unwrap();
let string = "<table class=\"datatable\"><thead><tr><tr></thead></table>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}